Jump to content

Karta wifi Broadcom


Recommended Posts

ja zas po instalacji na lenovo z565 czy to MXlinux  czy tez mint xfce 18.3 mam problem z wifi BCM 4352 ac , po instalacji kernela powyzej 4.15  przestaje mi widziec sieci i dzialac wifi ,czy to czysty kernel czy tez xanmod lub liquorix :wacko:

nie wiem jak to naprawic 

lan dziala ok

Link to post
Share on other sites
W dniu 18.06.2019 o 17:01, jou300 napisał:

Witam, szukam dystrybucji, która automatycznie wykryje sterowniki broadcom wifi. Jak narazie znalazłem mageia, ale mi nie leży. Czy znacie jakieś dystrybucję w sparciem broadcom ?

Ja mam też broadkoma i super działa z tym linux Q4os , wymagania ok 65mb i wszystkomający i zero problemów z wifi .

Link to post
Share on other sites
17 minut temu, berthold61 napisał:

Ja mam też broadkoma i super działa z tym linux Q4os , wymagania ok 65mb i wszystkomający i zero problemów z wifi .

a jaki model masz kolego taki jak ja ?

jesli tak to wez zainstaluj na probe najnowszy kernel i zobacz czy ci bedzie dzialac wifi nadal ok

Link to post
Share on other sites

No przecież ci pisałem że linux działał idealnie na tej karcie zwłaszcza q4os bo linuxmint miał z tym problem a np ubuntu nie byłem w stanie uruchomić tzw wifi mimo że mint to taki inny ubuntu, sprawdź sobie tą dystrybucję Q4os a zobaczysz przecież to tylko z pena odpalasz bez instalacji i już wiesz czy działa czy nie .

[Zawartość widoczna tylko dla zalogowanych użytkowników]

Link to post
Share on other sites

z pena mi nic nie da sprawdzenie , pisalem ci ze ja mam problem po UPDATE jak zrobie kernel powyzej 4.15 czy to orginal czy modowany

to mi nie dziala wifi

a na usb live nie idzie zainstalowac kernela i sprawdzic bez reboot

testowalem bo instalowalem wpierwej na MXlinux i teraz siedze na mint xfce i  lipa ,wiec  zostawilem kernel 4.15 zeby wifi dzialalo, ale mnie to wku.ia ze nie dziala mi wifi na nowszych kernelach :(

 

ps. czy mozesz u siebie zainstalowac na probe najnowszy kernel xanmod i zobaczyc czy ci zadziala wifi ?

Link to post
Share on other sites

@G77 z jakiego drivera do tej karty Broadcoma korzystasz?

 

Ja mam kartę BCM4360  z broadcom-sta i musiałem go modować, bo nie chciał działać z kernelem powyżej 5.0.

Konkretnie używam: broadcom-sta-dkms-6.30.223.271-5.1.rc.

*wg Google twoja karta też powinna działać z broadcom-sta.

Sam mod opisany jest [Zawartość widoczna tylko dla zalogowanych użytkowników] mam już zmodowane i zapisane te sterowniki, jak coś, to mogę podesłać.

Aktualnie na kernelu 5.2.2 Wi-Fi działa mi poprawnie :)

 

Konkretnie trzeba zmienić po jednej linijce w dwóch plikach:

N5jSHNO.jpg

G77 likes this
Link to post
Share on other sites

Na początek pytanie:  czy w /usr/src/ masz katalog broadcom-sta? (u mnie jest to katalog broadcom-sta-6.30.223.271)

Sprawdzisz komendą:

Cytat

dpkg --get-selections | grep broadcom-sta*

Jeśli tak, to pobierz tą paczkę: [Zawartość widoczna tylko dla zalogowanych użytkowników] i wypakuj ją do katalogu /usr/src/broadcom-sta_TWOJA_WERSJA/ folder src ma zostać scalony z folderem src który jest w katalogu broadcom. W tej paczce są dwa zmodowane pliki, które odpalą tą kartę pod nowszymi kernelami.

Po podmianie plików (zamieniasz te dwa, które są stare) instalujesz nowszy kernel, standardowo sudo update-grub i hula.

G77 likes this
Link to post
Share on other sites

Aktualizacja Anno Domini 2021:

Na Debianie 10 pod Broadcom'a wystarcza:

[Zawartość widoczna tylko dla zalogowanych użytkowników]

 

Broadcom STA is a binary-only device driver to support the following IEEE 802.11a/b/g/n wireless network cards: BCM4311-, BCM4312-, BCM4313-, BCM4321-, BCM4322-, BCM43142-, BCM43224-, BCM43225-, BCM43227-, BCM43228-, BCM4331-, BCM4360-, and BCM4352-based hardware.

 

Bądź kernel XanMod: [Zawartość widoczna tylko dla zalogowanych użytkowników] - ma ten driver wbudowany.

Korzystam z 5.11.6-xanmod1 na Debianie 10 i polecam, działa to dużo szybciej od zwykłego z backports.

G77 likes this
Link to post
Share on other sites
W dniu 24.07.2019 o 20:53, razor1995 napisał:

Na początek pytanie:  czy w /usr/src/ masz katalog broadcom-sta? (u mnie jest to katalog broadcom-sta-6.30.223.271)

Sprawdzisz komendą:

Jeśli tak, to pobierz tą paczkę: [Zawartość widoczna tylko dla zalogowanych użytkowników] i wypakuj ją do katalogu /usr/src/broadcom-sta_TWOJA_WERSJA/ folder src ma zostać scalony z folderem src który jest w katalogu broadcom. W tej paczce są dwa zmodowane pliki, które odpalą tą kartę pod nowszymi kernelami.

Po podmianie plików (zamieniasz te dwa, które są stare) instalujesz nowszy kernel, standardowo sudo update-grub i hula.

kolego moglbys wyslac jeszcze raz ta paczke ,bo link umarł  

 

ps. niestety ale na linux lite  4.8 nie dziala sudo apt install broadcom-sta-*  , a po instaacji xanmod-cacule 5.11.6      wifi nie dziala  :(

Link to post
Share on other sites
25 minut temu, WolframPL napisał:

Jeśli jestem w stanie jakoś pomóc, to przesyłam linka repo Debiana

[Zawartość widoczna tylko dla zalogowanych użytkowników]

pozdro

Wysłane z mojego SM-N950F przy użyciu Tapatalka
 

zdjelem z synapticka   zainstalowalem broadcom-sta-6.30.223.271   reebot i nadal brak wifi :(

wracam na 4.19 kernel tam dziala czy to orginal czy xanmod 

Link to post
Share on other sites
6 godzin temu, G77 napisał:

kolego moglbys wyslac jeszcze raz ta paczke ,bo link umarł  

 

Nie mam.

U mnie na STA działa normalnie. Doinstalowałeś kernel-headers? Bez tego u mnie sterownik się zainstalował, ale nie działał.

Napisz, jakie masz distro, jaki dokładnie model karty Wi-Fi i kernel, coś pokombinuję - latam teraz na Linuxie i jestem na bieżąco :E 

G77 likes this
Link to post
Share on other sites
Godzinę temu, razor1995 napisał:

Nie mam.

U mnie na STA działa normalnie. Doinstalowałeś kernel-headers? Bez tego u mnie sterownik się zainstalował, ale nie działał.

Napisz, jakie masz distro, jaki dokładnie model karty Wi-Fi i kernel, coś pokombinuję - latam teraz na Linuxie i jestem na bieżąco :E 

BCM 4352 ac ,  linux lite 4.8 ,lenovo z565 

kiedys mi sie udalo po twoich poradach , ale w tej chwili nie dziala powyzej 4.19.100 lub 4.19.102 xanmod 

instaluje image zawsze z kernelem i patch w wersji xanmod tez

Link to post
Share on other sites

Sposób na kernele 5.9 i wyższe:

[Zawartość widoczna tylko dla zalogowanych użytkowników] [Zawartość widoczna tylko dla zalogowanych użytkowników] [Zawartość widoczna tylko dla zalogowanych użytkowników]

 

Potwierdzam, że działa na 5.10.26-051026-lowlatency.

Edit:

Działa również na Ubuntu 21.04 i 5.12.0-xanmod1, którego obecnie używam.

Uwaga: Najlepiej instalować już na zbootowanym kernelu, którego używamy - mniej problemów.

Link to post
Share on other sites
W dniu 17.03.2021 o 21:04, razor1995 napisał:

Aktualizacja Anno Domini 2021:

Na Debianie 10 pod Broadcom'a wystarcza:

[Zawartość widoczna tylko dla zalogowanych użytkowników]

 

Broadcom STA is a binary-only device driver to support the following IEEE 802.11a/b/g/n wireless network cards: BCM4311-, BCM4312-, BCM4313-, BCM4321-, BCM4322-, BCM43142-, BCM43224-, BCM43225-, BCM43227-, BCM43228-, BCM4331-, BCM4360-, and BCM4352-based hardware.

 

Bądź kernel XanMod: [Zawartość widoczna tylko dla zalogowanych użytkowników] - ma ten driver wbudowany.

Korzystam z 5.11.6-xanmod1 na Debianie 10 i polecam, działa to dużo szybciej od zwykłego z backports.

to ten masz zainstalowany ziomus?

https://sourceforge.net/projects/xanmod/files/releases/edge/5.11.6-xanmod1/

Link to post
Share on other sites
W dniu 12.04.2021 o 14:50, razor1995 napisał:

Miałem ten.

Ale przesiadłem się na Ubuntu z 5.10.26-051026-lowlatency - jak napisałem wyżej.

Ten sposób działa:

 

a czemu sie przesiadles z xanmod na lowlatency?

Link to post
Share on other sites
W dniu 26.03.2021 o 19:19, razor1995 napisał:

Sposób na kernele 5.9 i wyższe:

[Zawartość widoczna tylko dla zalogowanych użytkowników] [Zawartość widoczna tylko dla zalogowanych użytkowników] [Zawartość widoczna tylko dla zalogowanych użytkowników]

 

Potwierdzam, że działa na 5.10.26-051026-lowlatency.

Edit:

Działa również na Ubuntu 21.04 i 5.12.0-xanmod1, którego obecnie używam.

Uwaga: Najlepiej instalować już na zbootowanym kernelu, którego używamy - mniej problemów.

1 linijka ok 

2 linijka ok 

3 blad jakis :(   jprdle z tym poj.nym wifi brcm

 

 

Support - [Zawartość widoczna tylko dla zalogowanych użytkowników] (Right click, Open Link)
 
 linuxlite  ~  sudo apt remove bcmwl-kernel-source
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Pakiet "bcmwl-kernel-source" nie jest zainstalowany, więc nie zostanie usunięty
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
 linuxlite  ~  wget [Zawartość widoczna tylko dla zalogowanych użytkowników]
--2021-04-27 18:42:00-- [Zawartość widoczna tylko dla zalogowanych użytkowników]
Translacja mirrors.kernel.org (mirrors.kernel.org)... 149.20.37.36, 2001:19d0:306:6:0:1994:3:14
Łączenie się z mirrors.kernel.org (mirrors.kernel.org)|149.20.37.36|:80... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 301 Moved Permanently
Lokalizacja: [Zawartość widoczna tylko dla zalogowanych użytkowników] [podążanie]
--2021-04-27 18:42:01-- [Zawartość widoczna tylko dla zalogowanych użytkowników]
Translacja mirrors.edge.kernel.org (mirrors.edge.kernel.org)... 147.75.101.1, 2604:1380:2001:3900::1
Łączenie się z mirrors.edge.kernel.org (mirrors.edge.kernel.org)|147.75.101.1|:80... połączono.
Żądanie HTTP wysłano, oczekiwanie na odpowiedź... 200 OK
Długość: 2202632 (2,1M) [application/octet-stream]
Zapis do: `broadcom-sta-dkms_6.30.223.271-15_all.deb.3'

broadcom-sta-dkms_6 100%[===================>]   2,10M   462KB/s    w 5,0s     

2021-04-27 18:42:06 (431 KB/s) - zapisano `broadcom-sta-dkms_6.30.223.271-15_all.deb.3' [2202632/2202632]

 linuxlite  ~  sudo dpkg -i broadcom-sta-dkms_6.30.223.271-15_all.deb
(Odczytywanie bazy danych ... 311618 plików i katalogów obecnie zainstalowanych.)
Przygotowywanie do rozpakowania pakietu broadcom-sta-dkms_6.30.223.271-15_all.deb ...
Rozpakowywanie pakietu broadcom-sta-dkms (6.30.223.271-15) ...
dpkg-deb (podproces): nie można skopiować członu archiwum z "broadcom-sta-dkms_6.30.223.271-15_all.deb" do potoku dekompresyjnego: niespodziewany koniec pliku lub strumienia
dpkg-deb (podproces): dekompresowanie członu archiwum: błąd lzma: niespodziewany koniec wejścia
dpkg-deb: błąd: podproces <dekompresja> zwrócił kod błędu 2
dpkg: błąd przetwarzania archiwum broadcom-sta-dkms_6.30.223.271-15_all.deb (--install):
 nie można skopiować wypakowanych danych "./usr/src/broadcom-sta-6.30.223.271/lib/wlc_hybrid.o_amd64" do "/usr/src/broadcom-sta-6.30.223.271/lib/wlc_hybrid.o_amd64.dpkg-new": niespodziewany koniec pliku lub strumienia
Wystąpiły błędy podczas przetwarzania:
 broadcom-sta-dkms_6.30.223.271-15_all.deb
 linuxlite  ~  


instaluje z pod LAN na juz na zainstalowanym 5.12 xanmod i mam image/kernel zainstalowane 

 

ps. teraz to nawet mnie nie dziala na starym kernelu co dzialalo japier..

dobrze ze mialem timeshift i odpalilem restore i na 5.8.18xanmod  wifi mnie dziala i zostaje juz nic nie kombinuje z tymi popier..mi sterami bcm:thumbdown:

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information