Skocz do zawartości
Liberton

Linux Lite x32 smiga, lecz w rozdzielczosci 640x480 :(

Rekomendowane odpowiedzi

Hej. Zainstalowalem na lapku dzis Linux Lite x32 i smiga jak zaden inny system dotad ale jest pewien problem. Pod karta Sis Mirage 3+ nie mozna ustawic rozdzielczosci na 1280x720 jak to domyslnie bylo w kazdym winowsie, ktory pobralem z tego forum.

Czytalem cos o Xorg-ach i innych fantazjach i nawet probowalem postepowac w terminalu tak jak bylo to przedstawione lecz bez efekow :(

Czy mogby mi ktos chetny i zanzajomiony pomoc doprowadzic rozdzielczosc do porzadku?

 

Przepraszam z gory za brak polskich liter lecz okno aktualizacji sterow jest dosc duze jak na te rozdzielczosc i nie moge zbyt duzo jak na te chwile zdzialac :P

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

cvt 1280 720 60 
Wyskoczy ci coś w stylu Modeline i to u dołu 

[Zawartość widoczna tylko dla zalogowanych użytkowników]

xrandr --newmode "1024x600_60.00" 48.96 1024 1064 1168 1312 600 601 604 622 -HSync +Vsync

xrandr --addmode X 1280x720_60.00

 

Za X wstaw wyjście monitora może to być VGA-0 
Sprawdzisz to pod Xrandr 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
13 minut temu, M4T  napisał:

Zapij zimną wodą, :E po prostu linux nie ma sterowników pod tą grafę i nie zmienisz rozdziałki :)

hmm czemu inni maja ?

 

Cytat

szef@szef:~$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 IDE Controller (rev 01)
00:03.0 USB controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
00:06.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:07.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
00:1f.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)
02:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 01)

 

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Cytat

szef@szef:~$ cvt 1280 720 60
# 1280x720 59.86 Hz (CVT 0.92M9) hsync: 44.77 kHz; pclk: 74.50 MHz
Modeline "1280x720_60.00"   74.50  1280 1344 1472 1664  720 723 728 748 -hsync +vsync

 

Cytat

szef@szef:~$ sudo leafpad /etc/X11/xorg.conf
[sudo] password for szef:

(leafpad:2634): IBUS-WARNING **: The owner of /home/szef/.config/ibus/bus is not root!

 

Leafpad otwiera mi pusty plik xorg.conf

\/\/\/\/\/\/

Powinienem wkleić w niego to, podmieniając na swojego modeline? :

Cytat
[Zawartość widoczna tylko dla zalogowanych użytkowników]

LSPCI - jak w poście powyżej

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jest na to inny sposób czyli plikiem EDID

Jeśli nie działa plik 90-mhwd możesz spróbować z xorgiem ale polecam najpierw tamten sposób.
Pamiętaj o zmianie linijki     Option "CustomEDID" "VGA-0:/etc/X11/edid.bin"                 
ZA VGA-0 dajesz swoj ekran plik edid możesz wrzucić do X11 ale musisz zmienic nazwę ścieżki albo zmienić nazwę pliku.
I jeszcze jedno, nie kopiuj tych trzech linijek tylko je wpisz bo przy kopiowaniu robią się błędy i wywala xorga :)

Pokaż jeszcze z ciekawości Xrandr z odpalonego linuxa live i lspci :)



Znalazłem ciekawe sterowniki : 
[Zawartość widoczna tylko dla zalogowanych użytkowników]
 

Pochodzą z listopada 2017 i są do twojej grafiki :D
Dobra nie pochodza z listopada 2017 a są wtedy wrzucone ale jest tam dużo plików więc może jakoś będą działaly :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Można spróbować jeszcze tego: [Zawartość widoczna tylko dla zalogowanych użytkowników]

2 minuty temu, M4T  napisał:

Co nie zmienia faktu że nie można zmienić rozdziałki :)

Fakt jest taki, że karta to zabytek, a i nigdy nie była jakoś specjalnie w Linuxach wspierana :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Problem rozwiązałem w inny sposób poprzez zmianę w pliku grub.cfg modułu gfx z auto na 1024x768. Sterwniki były tak samo jak i xorg lecz wina leżała w domyślnym rozmiarze bootownia.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

KArta nie jest już wspierana przez oficjalny ster Xorg "sis"  

NA standardowym sterowniku VGA nie pociągniesz wiecej niż 1024.

W grubie ustawiłeś tylko bufor ramki defaultowo było 640 .

 

Jest jeszcze stary sterownik X–ów juz nie wspierany oficjalnie , ale niektóre dystrybucje wspierały go dłużej.

Np oparte o Ubuntu 16.04. i zdaje się twoja wersja jest na tym oparta.

Tutaj masz link do skompilowanego sterownika lub możesz skompilować samemu.

 

[Zawartość widoczna tylko dla zalogowanych użytkowników]

 

Limitem jest Xorg =< 1.19 bo w wyższych sie abi pozmieniało.

JAk rozpakujesz  do  

/usr/lib/xorg/modules/drivers/sisimedia_drv.so

Skompilowana  paczka RPM wiec musisz wyodrębnić sterownik

jakimś narzędziem typu np. rpm2tgz  lub innym.

powinno chodzic na twoim lite w rozdzielczości 1280x800.

Jak nie. Skompilować ze źródeł tez w linku.

Gotowy plik konfiguracyjny Xorga jest w środku i jego tez kopiujesz do

/etc/X11/xorg.conf

lub

/etc/X11/xorg.conf.d/xorg.conf

w zależności która lokalizacje twoja dystrybucja wspiera.

 

Automatem Xorg nic nie ustawi bo sterownik nie wspiera trybu modeseting wiec xorg.conf jest wymagany.

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×

Powiadomienie o plikach cookie