Jump to content

2 kopie systemu na dwóch dyskach - problem z bootloaderem


ropi
 Share

Recommended Posts

Z pewnych względów chciałem w komputerze zainstalować dwie kopie tego samego systemu, które byłyby uruchamiane alternatywnie z dwóch dysków (GPT). wykorzystując menedżer bootowania płyty głównej. System z dysku A sklonowałem na dysk B. Po uruchomieniu systemu okazało się jednak, że gdy bootowanie następuje z dysku A, to system staruje z B. Jak i czym naprawić ten defekt?

Link to comment
Share on other sites

Dziękuję za odzew. Jednak to nie działa - może coś więcej trzeba wiedzieć? Program instaluje się na partycji systemowej dysku B (tak przynajmniej sygnalizuje). Nowy wpis wymaga podania litery przypisanej do partycji systemowej dysku A (oczywiście nie jest to już 'C'). Wymaga to, by partycja ta była widoczna w systemie B (trudno - niech i tak będzie). Po restarcie systemu pojawiła się możliwość wyboru dwóch systemów, ale niestety wybór systemu na dysku A prowadzi do zawieszenia się systemu. Po kilku próbach różnych wersji startu (łącznie z wyborem dysku bootowalnego z poziomu menu komputera) wpis dot. drugiego systemu zniknął z EasyBCD.

r.

Link to comment
Share on other sites

Tak to jest, jak się człowiek bawi na tych posranych partycjach GPT. Rozumiem, że pierwotnie nie chciałeś dodawać wpisu do BCD, tylko mieć dwa niezależne systemy na dwóch dyskach, a bootowanie wybierać z poziomu BIOS/UEFI? Jeśli tak, to nie wiem, co mogło się porąbać. Albo ty coś źle zrobiłeś, albo program do klonowania. W ogóle to ten system z dysku  A  startuje, jak nie ma podpiętego dysku B? Bo coś mi się wydaje, że chyba nie.

P.S. Ja takie rzeczy robiłem wielokrotnie, ale na partycjach MBR, używając Acronisa, i zero problemów.

Link to comment
Share on other sites

1 godzinę temu, Widzior napisał:

Rozumiem, że pierwotnie nie chciałeś dodawać wpisu do BCD, tylko mieć dwa niezależne systemy na dwóch dyskach, a bootowanie wybierać z poziomu BIOS/UEFI?

Właśnie tak napisałem.

 

1 godzinę temu, Widzior napisał:

Jeśli tak, to nie wiem, co mogło się porąbać. Albo ty coś źle zrobiłeś, albo program do klonowania.

 

Na jedno wychodzie niestety.

 

1 godzinę temu, Widzior napisał:

W ogóle to ten system z dysku  A  startuje, jak nie ma podpiętego dysku B? Bo coś mi się wydaje, że chyba nie.

 

Nie startuje. W tym rzecz.

 

1 godzinę temu, Widzior napisał:

P.S. Ja takie rzeczy robiłem wielokrotnie, ale na partycjach MBR, używając Acronisa, i zero problemów.

Ja też i nie tylko Acronisem. Natomiast nie jest to pierwszy mój przypadek z EasyBCD. Może czegoś tu nie rozumiem, ale dla uruchamiania wielu systemów windows to nie ma tu zbyt wielu możliwości. Może jakiś inny bootmenedżer zastosować? Do tego BIOS/UEFI jakby żył własnym życiem - dysk A jest na liście bootowania (mam na myśli wybór urządzenia z poziomu BIOS/UEFI) zawsze, ale B już czasem tylko w trybie "legacy".

Link to comment
Share on other sites

13 godzin temu, renatan napisał:

[Zawartość widoczna tylko dla zalogowanych użytkowników]

Ciekawe - wypróbuję. Dodam, że mam pendrive instalacyjny i oczywiście spróbowałem naprawy z jego poziomu, ale co ciekawe ta wersja systemu nie ma modułu naprawczego, a przynajmniej nie zgłasza się on tam, gdzie zwykle i program zabiera się od razu do ponownej instalacji systemu.

Link to comment
Share on other sites

Zrobiłem kolejne próby, ale bez powodzenia. Ostatecznie przywróciłem system na dysku A z obrazu. To jednak nie rozwiązało problemu. System nie chciał się uruchamiać. Dopiero wyłączenie dysku B spowodowało, że system z A startuje. Dodam, że dysk A to NVMw, a B - SATA. W biosie/uefi ustawiałem kolejność bootowania 1-A, 2-B. Wygląda jednak na to, że mimo ustawienia priorytetu na A najpierw chce startować B, ale ponieważ B był dodany później coś musiało się zmienić również na A i teraz nie działa.  Nie pomagają priorytety bootowania, ani ręczny wybór dysku z menu bootowania uefi. Dodam, że obecnie uefi pokazuje na liście bootowania (nie w setupie, a przy starcie) tylko dysk A, jako bootowalny w trybie uefi, a B - 'legacy' - i to nie działa.

Mogę spróbować skopiować dysk A innym narzędziem (poprzednio była to clonezilla) np. poprzez wykonanie kopii obrazu na drugi nośnik. Ale czy warto? Jeśli clonezilla nie namieszała - efekt będzie jak za pierwszym razem.

Na koniec dodatkowe informacje - system wykrywa dyski w kolejności 1-SATA (mój B), 2-NVMe (A). Przypomnę, że zaczynałem od A, a potem dołożyłem B.

Jakieś sugestie co dalej robić?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...

Important Information