Jump to content
WinClub
sc0rpow

NET. Framework nie chce się zainstalować na Win 7 RTM SP1

Recommended Posts

Witam, od ponad 5 lat mam nagranego na pendrive Windowsa 7 RTM + SP1. Oryginalny obraz .ISO z 12.05.2011. Tak samo jak od kilku lat mam nagranego na innym pendrive NET.Framework 4.6.2 Offline installer. Przez te kilka ostatnich lat instalowałem tego Windowsa i tego net frameworka niezliczoną ilość razy na komputerze, który nigdy nie jest podłączany do internetu. Ani razu nie było z tym problemu. Wczoraj robiłem reinstal ponownie i przy próbie instalacji net.framework'a pojawił się taki komunikat:

Cytat

 

Instalacja nie powiodła się.

Program .NET Framework 4.6.2 nie został zainstalowany, ponieważ:

Nie można wbudować łańcucha certyfikatów do zaufanego urzędu głównego. 

 

Spróbowałem zainstalować innego (też offline), ale to samo. W końcu podłączyłem tego starego PC do neta - i zero poprawy, ten sam problem. 

W końcu pobrałem najnowszą wersję ze wszystkimi aktualizacjami windows (datowaną na luty 2020) i net framework instaluje się bez problemów.

 

Moje pytanie brzmi - jakim cudem NET Framework (offline installer) bez problemów instalował się tyle razy na komputerze ze starym, nieaktualizowanym Windowsem, a teraz nagle nie chce? Skąd wie, że mam nieaktualny system, skoro komputer nigdy nie był podłączany do internetu? I dlaczego do tak podstawowej rzeczy jak stary NET. Framework 4.6.2 nagle potrzeba aktualnego systemu, skoro przez tyle lat dawało się go instalować na wersji RTM+SP1 z 2011 roku? 

Share this post


Link to post
Share on other sites
5 godzin temu, renatan napisał:

razor dał namiar na skrypt do instalacji

 

Skrypt do poprawek .NET 4.8 ESU.

Autor instaluje .NET 4.6.2 na czystym systemie RTM bez aktualizacji, czytałeś pierwszy post? :L 

 

@sc0rpow, korzystasz z instalatora, który miałeś gdzieś zarchiwizowany? Dobrze rozumiem? 

.NET 4.6 ma w prereq jedynie SP1, więc powinien bez problemu się zainstalować ([Zawartość widoczna tylko dla zalogowanych użytkowników])

 

Share this post


Link to post
Share on other sites
47 minut temu, razor1995 napisał:

Skrypt do poprawek .NET 4.8 ESU.

Autor instaluje .NET 4.6.2 na czystym systemie RTM bez aktualizacji, czytałeś pierwszy post? :L 

 

@sc0rpow, korzystasz z instalatora, który miałeś gdzieś zarchiwizowany? Dobrze rozumiem? 

.NET 4.6 ma w prereq jedynie SP1, więc powinien bez problemu się zainstalować ([Zawartość widoczna tylko dla zalogowanych użytkowników])

 

Tak, miałem zarchiwizowanego NET. Frameworka 4.6.2. Na początku myślałem, że instalka się w jakiś sposób i ściągnąłem z neta idetyczną wersję, ale problem był ten sam. Oczywiście mówię cały czas o instalacji na Windowsie 7 64-Bit + SP1. Wcześniej przez cały czas nie było problemów z instalowaniem na nim tej konkretnej wersji net framework. Dlatego mocno się zdziwiłem co się nagle odwaliło, że wyrzuca błąd podczas instalacji. 

Share this post


Link to post
Share on other sites

Już wszystko jasne. Okazuje się, że wersja Win 7 + SP1 RTM (2011) ma sama w sobie jakiś certyfikat, który wygasł wraz z dniem wsparcia Windowsa. Bez tego nie da się już w normalny sposób zainstalować NET FRAMEWORKA. Trzeba pobrać certyfikat o nazwie: "MicRooCerAut2011_2011_03_22", otworzyć go i zainstalować w folderze "zaufane główne urzędy certyfikacji". Po tej czynności każdy net framework instaluje się bez problemów nawet w starszych, nieaktualizowanych wersjach Windowsa 7.

razor1995 likes this

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information