Jump to content
WinClub
gabriel0

b450 a pro max nie działają 2 usb.

Recommended Posts

Witam.
Od trzech miesięcy jestem posiadaczem b450 a pro max. Nie działają mi na niej 2 sztuki usb 3.0. Dwa pozostałe 3.0 i dwa 2.0 pracują poprawnie. Czy po instalacji wszelakich sterowników mogę podejrzewać uszkodzenie hardware? Trochę boli mnie oddawanie komputera na gwarancję gdyż jest wykorzystywany cały czas.

Wedle folderu reklamowego są to usb 3.2 gen1. Usb w obudowie na przednim panelu (3.0) pracują poprawnie.
System 7 64bit
 

[Zawartość widoczna tylko dla zalogowanych użytkowników]

[Zawartość widoczna tylko dla zalogowanych użytkowników]

Share this post


Link to post
Share on other sites

Zasadnicze pytanie, na które nie dałeś odpowiedzi - czy to Ryzen serii 3000 na Win7? Jeśli tak, to jest to normalne. Nie działają ci USB z tyłu, czyli w terminologii AMD USB 3.0, wychodzące bezpośrednio z procesora (AMD nie daje do nich sterowników pod Win7). USB 3.1 to te z chipsetu. m.in. na przednim panelu. Tu masz mój temat z opisem co i jak, wystarczyło poszukać, masz tam też link do tego, jak zmodyfikować drivery, żeby te USB działały na Win7 -

P.S. Jak to dla ciebie zbyt trudne, to podaj maila, to ci wyślę zmodyfikowane drivery. Sam już je sobie przygotowałem, w oczekiwaniu na zakup Ryzena 3600 i jestem ciekaw, czy to zadziała na 100%, bo są opinie, że ta modyfikacja działa bez problemu, USB śmigają, ale niestety czasem pojawia się w systemie BSOD :) W najgorszym przypadku trzeba będzie pod Win7 z tych USB zrezygnować. I jeszcze jedno - dlaczego nie masz poinstalowanych innych sterowników AMD Chipsets? Tak wynika ze screenu. Musisz to zrobić przed wrzuceniem tych modowanych USB.

Share this post


Link to post
Share on other sites

Dziękuję za odpowiedź. Tak, mam 7demkę i ryzena 3700x
Zainstalowałem wszystko co znalazłem na stronie amd. Niestety system jakoś głupio nie wykrywa tego. Tak samo jak "Nieznane urządzenie" jest to z tego co doczytałem sterownik bluetooth do HTC vive. Bluetooth ten działa prawidłowo.
Mogę z nich zrezygnować, gdybym tylko dowiedział się gdzie kupić jakieś złącze usb 2.0 do wepchnięcia w wolny slot z tyłu komputera, podobnież ta płyta obsługuje 4 sztuki 2.0.

Jeżeli chcesz by ci przeprowadzić jakieś testy tego procesora/ płyty na 7-demce itp to śmiało pisz.
Aha, no i 3.2 gen 2 z tyłu działają prawidłowo.

Share this post


Link to post
Share on other sites
38 minut temu, gabriel0 napisał:

, gdybym tylko dowiedział się gdzie kupić jakieś złącze usb 2.0 do wepchnięcia w wolny slot z tyłu komputera, podobnież ta płyta obsługuje 4 sztuki 2.0.
 

 

Wszędzie

[Zawartość widoczna tylko dla zalogowanych użytkowników]

Share this post


Link to post
Share on other sites

Dziękuję. Nie mogłem znaleźć sprzętu z powodu braku znajomości odpowiedniej terminologii :mellow:
Temat z moim 3.0 mogę uznać za wstępnie nieaktualny, gdyż po zakupieniu "śledzia" będą mi zbędne.

 

Share this post


Link to post
Share on other sites

Kolega @Widzior podał ci sposób modyfikacji sterowników, tak, aby działały również te "wychodzące" z procesora. Już wiesz jaki śledź kupić, aby wykorzystać porty USB 2.0 wychodzące z płyty. Podpowiem ci jeszcze 3 sposób - możesz kupić adapter PCI-E x1 na USB 3.0 lub 2.0:

- przykład 3.0: [Zawartość widoczna tylko dla zalogowanych użytkowników]

- przykład 2.0: [Zawartość widoczna tylko dla zalogowanych użytkowników]

 

 

Share this post


Link to post
Share on other sites

Ten "Kontroler szyfrowania/odszyfrowywania PCI" to "AMD PSP 3.0 Device" i rzeczywiście tu też trzeba zmodyfikować sterownik, żeby zaskoczyło. Martwi mnie natomiast brak sterownika do "Urządzenie PCI", o tym nie słyszałem, że nie wchodzi. U mnie to "AMD PCI", dwie sztuki, w Urządzenia Systemowe. A poza tym to masz i tak fuksa, że kupiłeś płytę, która ma tylko 2x USB 3.0 wychodzące z CPU na tylnym panelu (sprawdziłem w manualu do mobo), bo większość ma 4 sztuki, choćby ten B450M Mortar, którego opisałem z tamtym temacie i na którego się czaję. A te 4 porty USB, które masz działające z tyłu (2x2.0 + 2x3.1 z chipsetu) plus te na przednim panelu, to ci nie wystarczą?

 

P.S. wrzucę od razu info, jak zmodyfikować sterownik do PSP 3.0 - Changing line 58 in the W7x64 amdpsp.inf to:  %amdpsp_30.DeviceDesc% = amdpsp_Device_30, PCI\VEN_1022&DEV_1486 ; Summit/Naples  Allows you to install this as AMD PSP 3.0 in Device Manager. Seems stable so far, but obviously done at one's own risk.

Share this post


Link to post
Share on other sites

Rozłożę to tak.
2.0 mam dwa
3.0 mam 4 czynne.
HTC vive jest pod 3.0, 3 odbiorniki do trackerów potrzebują 2.0, podpiąłem pod 3.0.
Zostały dwa wolne 2.0. Jeden to mysz 2gi jest zbędny. Ale żeby wtyknąć jakiś pendrive to muszę kompa odsuwać, a nie na tym rzecz polega. Kupię śledzia, wetknę odbiorniki od trackerów z tyłu i będzie po problemach.

Urządzenie PCI to co to może oznaczać?
jest to coś takiego
PCI\VEN_10DE&DEV_1ADB&SUBSYS_86FC1043&REV_A1
PCI\VEN_1022&DEV_1481&SUBSYS_7B861462&REV_00
Jeżeli nie przeszkadza w wydajności komputera to niech sobie będzie.

W sumie wszystko co mi potrzeba chodzi okej, nie będę tu szukał dziury w całym. Może jeszcze jak mi odwali to kupię dysk M.2 i od nowa postawię 7-demkę której do tego trzeba zintegrować sterowniki (tak słyszałem), ale więcej modyfikacji nie przewiduję.
Z komputera i tak korzystam tylko do gogli VR, na roboczo mam wysłużonego XP-ka a do podłączania samochodów 2000 z portem COM.

 

Share this post


Link to post
Share on other sites

Jak będziesz chciał się pobawić, to tu masz zmodowane przez mnie sterowniki USB 3.0 i PSP 3.0. Dodatkowo wrzuciłem zwykłe PCI z paczki AMD Chipset Drivers, które nie wiem czemu u ciebie nie zaskoczyły, może te zaskoczą - [Zawartość widoczna tylko dla zalogowanych użytkowników]  Oczywiście info o braku podpisu cyfrowego będziesz miał.

gabriel0 likes this

Share this post


Link to post
Share on other sites
37 minut temu, gabriel0 napisał:

Może jeszcze jak mi odwali to kupię dysk M.2 i od nowa postawię 7-demkę której do tego trzeba zintegrować sterowniki (tak słyszałem),

Od razu podpowiem - kup dysk producenta oferującego sterowniki NVMe do Win 7, żebyś nie miał kłopotów.

gabriel0 likes this

Share this post


Link to post
Share on other sites

[Zawartość widoczna tylko dla zalogowanych użytkowników]

Sytuacja wygląda tak.
PSP weszło (nie wiem nawet co to jest)
oraz jeden z usb niby wszedł, ale usb nie działają nadal.
Instalowałem przez menadżer urządzeń, zaaktualizuj sterownik i podawałem ścieżkę do tego co mi podesłałeś.
Tyle z ciekawostek. Śledzie już w drodze :)

Share this post


Link to post
Share on other sites

Pokaż, co masz w "Kontrolery uniwersalnej magistrali szeregowej". Powinieneś mieć 2x3.0 (USB z CPU) i 2x3.1 (USB z chipsetu). Tak to u mnie wygląda -

[Zawartość widoczna tylko dla zalogowanych użytkowników]

Share this post


Link to post
Share on other sites

Czyli wygląda na to że brakuje tego xHCI . Niestety nic więcej nie daje się zainstalować.

[Zawartość widoczna tylko dla zalogowanych użytkowników]

Share this post


Link to post
Share on other sites

Z tego co widzę, to wszedł ci ten sterownik, który zmodowałem, czyli amdxhci.sys. Nie wszedł ci Root Hub, nie wiem dlaczego, bo go nie trzeba zmieniać i go nie ruszałem. W każdym razie ta metoda, jak piałem wcześniej, nie wszystkim działa lub powoduje losowe BSODy, więc odinstaluj ten sterownik AMD USB3 Host Controller i sprawdź jeszcze te sterowniki, bo podobno działają bez żadnych problemów czy losowych BSODów. Sprawdź wpierw te z katalogu SHA256, one mają podpis cyfrowy, więc przejdą bez problemu. Gdyby jednak coś nie działało, to sprawdź też te z katalogu SHA1 (one nie mają podpisu SHA256, więc wyskoczy odpowiednie czerwone info). Po zainstalowaniu powinieneś mieć te dwa brakujące kontrolery: AMD Root Hub(xHCI) i AMD USB3 Host Controller w wersji 2.0.0.49 (tak sobie moder wymyślił, bo oryginalne są 2.0.0.48). Link do paczki - [Zawartość widoczna tylko dla zalogowanych użytkowników]

Share this post


Link to post
Share on other sites

Poczyniłem dwie próby odinstalowania. Przy każdej wysypuje mi system. Zostawię to w holerę, gdyż narazie wszystko działa. Śledzie przyszły, trochę cienka blacha, no ale działa. Nikt tam nie będzie cały czas heblował kablami w tych portach.
Dziękuję za wszelaką pomoc. Pozdrawiam!

Share this post


Link to post
Share on other sites

Ehh to mnie teraz nastraszyłeś, myślałem, że z tymi modowanymi USB to prosta sprawa, że zmienili tylko po złości ID urządzenia. Ale żeby ci system wysypywało odinstalowanie drivera USB? Mogłeś w takim razie po prostu zrobić aktualizację tego sterownika, wskazać na te nowe zmodowane drivery i pewnie z automatu by podmienił, a jak nie, to zawsze można wymusić opcją "Z dysku" i wybrać z listy. Widzę sam będę musiał to rozkminić jak kupię Ryśka 3600 :E

Share this post


Link to post
Share on other sites

Jak to NVMe, to powodzenia, no chyba że ma sterowniki do Win7. A te sterowniki modowane do USB z CPU to ludziom działają, nie wiem co ty pokombinowałeś, że ci sypało BSODami. Są już nawet nowsze wersje, ale niby mniej stabilne.

Share this post


Link to post
Share on other sites

Wszystko lata, tylko chodziło mi o sterowniki które podałeś mi z linku na megawrzutę. Chciałem zainstalować to PSP które tam było.

Share this post


Link to post
Share on other sites

No i jak sprawa wygląda z tymi USB z procesora na tylnym panelu? Zainstalowałeś w końcu te zmodyfikowane sterowniki 2.0.0.49? A tego PSP do niczego nie potrzebujesz, ale jak chcesz, to tu masz świeżą wrzutkę - [Zawartość widoczna tylko dla zalogowanych użytkowników]

Share this post


Link to post
Share on other sites

Tak jak napisałem na PW.
Zostawię tu dla potomnych wszystkie sterowniki powchodziły stąd [Zawartość widoczna tylko dla zalogowanych użytkowników]
USB z procka działają. Wstępnie nie widzę żadnych nieprawidłowości.

Share this post


Link to post
Share on other sites

Ten link do win-raid jest też w tym moim temacie o Ryzenach 3000 na Win7, i wiktorynka (zrobił super zbiorczy temat). Ale dobrze wiedzieć, że te stery canonkong'a działają. Jednak nie są w 100% idealne. Wiele osób w tamtym temacie pisze, że mają problemy z dźwiękiem z karty dźwiękowej USB podpiętej pod te modowane wejścia z tyłu. Ty mi na PW pisałeś o problemach z Googlami VR. Wychodzi na to, że do podpięcia pendrive są OK, ale z bardziej zaawansowanymi sprzętami może być różnie. Ja jak już w końcu kupię nowego Ryża, to chyba całkiem je oleję. Te dwa USB 3.0 z chipsetu na front panelu mi w zupełności wystarczają.

Share this post


Link to post
Share on other sites

Zawsze można dołożyć adapter PCI-E x1 na USB 3.0 (2 - 4 porty USB 3.0) - są na zewnętrznym kontrolerze, więc działają wszędzie. Szczególnie polecana opcja na płyty Intela z chipsetami 14nm H370, B360, H310 gdzie nie działa żaden port USB 3.0 z chipsetu/procesora pod Win 7. Drugie znakomite zastosowanie, to starsze płyty z USB 2.0 tylko. Nawet LGA775 można ożywić.

Share this post


Link to post
Share on other sites

Wyjaśniam sytuację.
Tylko te z procka mi nie działały.
HTC VIVE chodził bez problemu na tych z chipsetu. Po zainstalowaniu sterowników z win-rad nie testowałem go na tych z procka.
PIMAX na tych z procka non stop się rozłącza i łączy. Na tych z chipsetu niby chodzi, ale to bardziej złożony temat.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information