Jump to content
WinClub
bladesss

Notoryczny problem z aktualizacją Win10 - 0xC1900101 - 0x20017

Recommended Posts

Witam,

na początku chciałbym się przywitać, jestem tu nowy. Potrzebuję pomocy ponieważ nic co jak dotąd znalazłem w internecie nie pomaga. Od jakoś pół roku mam problem z aktualizacją windowsa, zaczął się bodajże przy próbie instalacji marcowej kompilacji. Za każdym razem pojawia się wspomniany błąd 0xC1900101 - 0x20017. W momencie gdy nie udało mi się zainstalować oficjalnej kompilacji zacząłem próbować instalować Insider Preview, również to samo. Raz udało mi się podnieść wersję w momencie gdy zepsułem sobie MBR i po jego naprawieniu instalacja poszła po czym od tego momentu dalej jest to samo, bez względu na kompilację systemu. Próbowałem chyba już wszystkiego (sfc, dism, naprawy/resety WU itp). Poradniki wskazują, że jest to niby problem ze sterownikami jednak, żaden ze sterowników nie zgłasza błędu, wszystko działa ok, w logach nie potrafię odnaleźć sterownika, który miałby powodować problem. Nie mam pewności ale wydaje mi się, że problem powstał po wgraniu niestandardowego sterownika NVME od Open Fabrics Alliance, ale przywróciłem już dawno ten od Microsoftu (a może to po prostu był zbieg okoliczności). W laptopie mam 2 dyski: jeden na m.2, drugi na sata, system stoi na tym m.2. W załączniku dodaję zipa z logami utworzonego przez microsoftowy SetupDiag.exe, może komuś uda się coś z nich wywnioskować
Pomocy :(

[Zawartość widoczna tylko dla zalogowanych użytkowników]

Share this post


Link to post
Share on other sites
10 minut temu, renatan napisał:

tez tu próbują [Zawartość widoczna tylko dla zalogowanych użytkowników]

i tu [Zawartość widoczna tylko dla zalogowanych użytkowników]

Wątków z tym błędem w internecie jest dużo więcej i w żadnym z nich nie ma działającego u mnie rozwiązania, do tego dochodzi fakt słabej znajomości j. angielskiego. Niby z logów da się coś wyciągnąć ale nigdzie nie jest napisane na co w tych logach trzeba patrzeć

Share this post


Link to post
Share on other sites

Masz pozostałości starych ( błędnych )  sterowników  i będzie tak  do póki  je nie wyczyścisz.

Prościej i szybciej  instalacja od nowa.

-  pobrać nowy win 10 dobry sprawdzony w miarę (  nie ma idealnego bo winzgroza to wielki  syf ) 

- na czas instalacji  wyjąć  drugi dysk ( zostawić tylko M2 )

- usunąć  bzdety telemetrię  itd.. - dostroić do swoich potrzeb ( już z podłączonym dyskiem 2 )

- instaluj tylko sterowniki od producenta nie inne ( wyłączyć instalacje od MS ) 

- Driver Booster Pro  -  " dociągnąć " nowsze sterowniki  ( instalować tylko po jednym nie inaczej bo jak wywali to wiesz jaki powoduje błąd i łatwo to naprawić )

- jak nic nie namieszasz to powinno wszystko działać OK  ( poczytaj poradniki  z forum ) . 

Share this post


Link to post
Share on other sites

Czysta instalacja odpada niestety - to laptop służbowy i mam na nim zbyt dużo pokonfigurowanych rzeczy, przywrócenie tego to chyba z tydzień roboty po czystej instalacji. Z wyjęciem drugiego dysku jest o tyle problem, że nie mam klapki na dysk, trzeba rozkręcać całą obudowę u mnie:/ Driver Boostera używałem też a i próbowałem też Snappy Driver. Jak można po logach odszukać problematyczny sterownik? Potrafi to ktoś?

Share this post


Link to post
Share on other sites
10 minut temu, bladesss napisał:

Czysta instalacja odpada niestety - to laptop służbowy

A co ma piernik do wiatraka !?

11 minut temu, bladesss napisał:

 mam na nim zbyt dużo pokonfigurowanych rzeczy, przywrócenie tego to chyba z tydzień roboty po czystej instalacji. 

:doh: tydzień !?  jak każdy  co zawodowo " grzebie  "  w  komp.......   miał by tydzień  robić to na sól by nie zarobił.

13 minut temu, bladesss napisał:

Z wyjęciem drugiego dysku jest o tyle problem, że nie mam klapki na dysk, trzeba rozkręcać całą obudowę 

No niestety  tak teraz robią  - w czym  problem ?.

15 minut temu, bladesss napisał:

 Driver. Jak można po logach odszukać problematyczny sterownik? Potrafi to ktoś?

Wszystko no prawie wszystko  można ,ale jest zawsze ryzyko że zobaczysz niebieski ekran i co wówczas !?  wszystkie dane  w " piach ".

Dlatego ( tym bardziej jak w Twoim przypadku )  robi się czystą instalację  ( porządną , działającą z tym co  potrzeba ) robi się kopie i w razie " draki "  masz bez problemu do stanu początkowego.

Podpowiadać  to tak jak by z fusów wróżyć  nie mając tego w " rękach " a w razie niepowodzenia pretensje do kogo będą ?.

Radzę Ci zrobić tak jak napisałem - raz a porządnie będzie szybciej no może jakimś cudem Ci się uda , ale czarno to widzę ?.

Share this post


Link to post
Share on other sites
22 minuty temu, woj_ani217 napisał:

A co ma piernik do wiatraka !?

:doh: tydzień !?  jak każdy  co zawodowo " grzebie  "  w  komp.......   miał by tydzień  robić to na sól by nie zarobił.

No niestety  tak teraz robią  - w czym  problem ?.

Wszystko no prawie wszystko  można ,ale jest zawsze ryzyko że zobaczysz niebieski ekran i co wówczas !?  wszystkie dane  w " piach ".

Dlatego ( tym bardziej jak w Twoim przypadku )  robi się czystą instalację  ( porządną , działającą z tym co  potrzeba ) robi się kopie i w razie " draki "  masz bez problemu do stanu początkowego.

Podpowiadać  to tak jak by z fusów wróżyć  nie mając tego w " rękach " a w razie niepowodzenia pretensje do kogo będą ?.

Radzę Ci zrobić tak jak napisałem - raz a porządnie będzie szybciej no może jakimś cudem Ci się uda , ale czarno to widzę ?.

Ja zawodowo nie grzebię w komputerach ale potrzebuję go do pracy, mogę sobie pozwolić na np pół godziny offline a tak już będzie to problematyczne. Format odpada i tyle, nie che mi się tłumaczyć specyfiki mojej pracy bo jest to nieistotne. Czemu miałbym mieć bsod'a po samym odszukaniu złego sterownika? Jeszcze nie powiedziałem co z nim zrobię :) Jeśli nie potrafisz go odszukać po logach wystarczy to napisać, nie każdy musi to potrafić, ale poczekam na kogoś kto może będzie potrafił. Nie będę przecież robił formata za każdym razem jak będę miał problem z aktualizacją...

 

 

11 minut temu, renatan napisał:

wejdź też do ..podgląd zdarzeń..tam możesz dojść do żródła konfliktu

z Podglądu Zdarzeń nie potrafię wyczytać nic konstruktywnego :/ 

Share this post


Link to post
Share on other sites

Znalazłem coś takiego:
[Zawartość widoczna tylko dla zalogowanych użytkowników]
Podejrzewam, że problem może leżeć właśnie w tym MBR, szczególnie że ostatnia udana próba instalacji odbyła się właśnie po tym jak nagrzebałem w MBR. Przebudowa MBR jest względnie łatwa tyle, że poprzednim razem zaskoczył mnie komunikat o braku uprawnień w połowie wykonywania komend. Mógłbym zrobić to ponownie ale boję się ponownego problemu. Czy ktoś wie jak odpalić wersję CMD z wyższymi uprawnieniami z poziomu winPE? (odpalany z instalki win i => "Naprawa komputera")

 

Share this post


Link to post
Share on other sites
44 minuty temu, bladesss napisał:

Format odpada i tyle, nie che mi się tłumaczyć specyfiki mojej pracy bo jest to nieistotne. 

Twoja  sprawa ,a ja z doświadczenia  wiem swoje.

46 minut temu, bladesss napisał:

 Czemu miałbym mieć bsod'a po samym odszukaniu złego sterownika? 

Po samym odszukaniu na pewno nie ! ,ale po odinstalowaniu lub  błędnej instalacji już tak  - mało jeszcze widziałeś i nie jedno jeszcze Ciebie zdziwi  .

49 minut temu, bladesss napisał:

Jeśli nie potrafisz go odszukać po logach wystarczy to napisać, nie każdy musi to potrafić, ale poczekam na kogoś kto może będzie potrafił.

Jeżeli  nie miał bym  wiedzy w tym temacie to nie zabierał bym w nim głosu  (  na pewno jak ja się tym zajmowałem to Ty może już oglądałeś kreskówki ? )  to nie jest takie pstryknięcie palcami i już gotowe !.

Przeglądałeś logi i co wyczytałeś nic bo nic o tym nie piszesz , bo  o tym nie masz zielonego pojęcia a wymagasz żeby " zielonemu "  kawę na ławę wyłożyć .

W tych Twoich logach  wielkie  G jest same ogólniki  ale :

 

Kod błędu : 0xC1900101

    HostOSEdition = Professional
    RegisteredAV = Windows Defender
    FilterDrivers = FileInfo
    UpgradeStartTime = 10.09.2019 09:59:57
    UpgradeEndTime = 10.09.2019 10:20:10
    UpgradeElapsedTime = 00:20:13
    CV = NhMHm8BOYEq2FRqs
    ReportId = B36B042B-4EAB-40CE-8ED0-8604E90FB68F


Error: SetupDiag reports rollback failure found.
Last Phase = Finalize
Last Operation = Remove System Restore checkpoints
Error = 0xC1900101-0x20017

 

i

 

Kod błędu :0x20017

    CV = ldL4m5ynCEWiJRvh
    ReportId = B36B042B-4EAB-40CE-8ED0-8604E90FB68F


Error: SetupDiag reports rollback failure found.
Last Phase = Finalize
Last Operation = Remove System Restore checkpoints
Error = 0xC1900101-0x20017

 

co w ogólnym  podglądzie daje  ogólnik  w szerokim pojęciu  co nawet sam MS  podaje cytuje :

 

Kody błędów systemu są bardzo szerokie: każdy z nich może wystąpić w jednej z wielu setek lokalizacji w systemie. W związku z tym opisy tych kodów nie mogą być bardzo szczegółowe. Korzystanie z tych kodów wymaga pewnej ilości badań i analiz. Należy zwrócić uwagę zarówno na kontekst programowy, jak i środowisko wykonawcze, w którym występują te błędy. Ponieważ kody te są zdefiniowane w WinError.h dla każdego do użytku, czasami kody są zwracane przez oprogramowanie niesystemowe. Czasami kod jest zwracany przez funkcję głęboko w stosie i daleko od kodu obsługującego błąd.

 

i co do sterowników nic konkretnego nie ma  to  wskazuje na  :

0xC1900101–0x20017 błąd przez aktualizację zbiorczą   i   tu należy najpierw  zajrzeć .

 

Nie wiem co tam instalowałeś ( sterowniki )  bo szklana kula mi się stłukła  ,ale głównym  problemem w sterownikach  są ( tym bardziej w win 10 )  chipset broadcom  - WiFi, Bluetooth , czy takich nie instalowałeś ,podłączyłeś ?.

 

 

Share this post


Link to post
Share on other sites
Godzinę temu, woj_ani217 napisał:

Twoja  sprawa ,a ja z doświadczenia  wiem swoje.

Czy ja gdzieś napisałem, że format nie będzie lepszym rozwiązaniem?? Napisałem, że nie mogę sobie na niego pozwolić i tyle.
 

 

Godzinę temu, woj_ani217 napisał:

Po samym odszukaniu na pewno nie ! ,ale po odinstalowaniu lub  błędnej instalacji już tak  - mało jeszcze widziałeś i nie jedno jeszcze Ciebie zdziwi  .

No to chyba najpierw trzeba odnaleźć źródło problemu i potem się zastanowić co z tym zrobić. Myślisz, że nie wiem, że odinstalowanie jakiegoś istotnego sterownika może spowodować crash? Ale chyba jest jeszcze możliwość wgrania nowszego/starszego? Czy się mylę?
 

 

Godzinę temu, woj_ani217 napisał:

Jeżeli  nie miał bym  wiedzy w tym temacie to nie zabierał bym w nim głosu  (  na pewno jak ja się tym zajmowałem to Ty może już oglądałeś kreskówki ? )  to nie jest takie pstryknięcie palcami i już gotowe !.

Jeśli masz lat 50+ to możliwe. Ale jeśli jedynym rozwiązaniem dla Ciebie jest format to o jakiej wiedzy tu mowa? Formata to dzieci z podstawówki potrafią zrobić

 

Godzinę temu, woj_ani217 napisał:

Przeglądałeś logi i co wyczytałeś nic bo nic o tym nie piszesz , bo  o tym nie masz zielonego pojęcia a wymagasz żeby " zielonemu "  kawę na ławę wyłożyć .

O logach wspomniałem w pierwszym poście, że nie idzie tam znaleźć problematycznego sterownika. Ja nic nie wymagam a poprosiłem o pomoc, ale nie w formacie bo to potrafię zrobić sam.

 

1 godzinę temu, woj_ani217 napisał:

W tych Twoich logach  wielkie  G jest same ogólniki

To akurat też zauważyłem
 

 

1 godzinę temu, woj_ani217 napisał:

i co do sterowników nic konkretnego nie ma  to  wskazuje na  :

0xC1900101–0x20017 błąd przez aktualizację zbiorczą   i   tu należy najpierw  zajrzeć .

 

Nie wiem co tam instalowałeś ( sterowniki )  bo szklana kula mi się stłukła  ,ale głównym  problemem w sterownikach  są ( tym bardziej w win 10 )  chipset broadcom  - WiFi, Bluetooth , czy takich nie instalowałeś ,podłączyłeś ?.


Co konkretnie masz na myśli, gdzie zajrzeć? Ten błąd się pokazuje przy każdej próbie instalacji dużej aktualizacji, zmieniającej numerek kompilacji. Chipset, wifi, bt były aktualizowane przez wspomniany Driver Booster ale już po wystąpieniu problemu

a odnośnie tego linka co wrzuciłem wyżej - ja też migrowałem system z hdd na ssd, więc może faktycznie mam jakieś błędne wpisy w sektorze rozruchowym. Postaram się jeszcze podziałać z tym

Share this post


Link to post
Share on other sites
Godzinę temu, bladesss napisał:

Jeśli masz lat 50+ to możliwe. Ale jeśli jedynym rozwiązaniem dla Ciebie jest format to o jakiej wiedzy tu mowa? Formata to dzieci z podstawówki potrafią zrobić

Koniec tej pustej  dyskusji  bo chociaż  masz już swoje lata  to ciężko  rozumujesz  i mnie porównujesz do  dzieci z podstawówki  to po co ze mną dyskutujesz  jak uważasz że mój  poziom wiedzy to  format  dysku  czego  Ty widzę nie potrafisz !.

Nie potrafisz zrobić kopi  użytkownika i oprogramowania z jakiego korzystasz  i przywrócić to po instalacji nowego WIN xxx.

Nie potrafisz  odinstalować  aktualizacji i nie wiesz gdzie je  szukać !? , a  mi wypominasz że się uczepiłem formatu  " jak pies kota ogona ".

Cztery godziny  pustej dyskusji  to już dwa razy bym to zrobił  i by działało jak trzeba.

Nr aktualizacji szukasz w ustawieniach > aktualizacje  i robisz to   w konsoli jako administrator:

np.

wusa /uninstall /kb:2976978

są i inne sposoby ,ale co ja tam wiem umiem tylko formatować.

Koniec kropka - powodzenia.

Share this post


Link to post
Share on other sites

Nie masz przypadkiem podpiętego jakiegoś modułu Broadcom Bluetooth and Wireless Network ? Jeśli masz drivery od takiego sprzętu w systemie to masz przyczynę takiego stanu rzeczy... [Zawartość widoczna tylko dla zalogowanych użytkowników] Ten błąd występował przy aktualizacji z Win7 lub Win8 na Win10 jak również po którejś aktualizacji Win10 gdy w systemie znajdowała się karta z chipsetem Broadcom.

Share this post


Link to post
Share on other sites
13 minut temu, marcelgg napisał:

Nie masz przypadkiem podpiętego jakiegoś modułu Broadcom Bluetooth and Wireless Network ? Jeśli masz drivery od takiego sprzętu w systemie to masz przyczynę takiego stanu rzeczy... [Zawartość widoczna tylko dla zalogowanych użytkowników] Ten błąd występował przy aktualizacji z Win7 lub Win8 na Win10 jak również po którejś aktualizacji Win10 gdy w systemie znajdowała się karta z chipsetem Broadcom.

Jak wklejasz  czyjś tekst  to  jako cytat bo mogą być pretensje.

Share this post


Link to post
Share on other sites
Godzinę temu, woj_ani217 napisał:

Koniec tej pustej  dyskusji  bo chociaż  masz już swoje lata  to ciężko  rozumujesz  i mnie porównujesz do  dzieci z podstawówki  to po co ze mną dyskutujesz  jak uważasz że mój  poziom wiedzy to  format  dysku  czego  Ty widzę nie potrafisz !.

Nie potrafisz zrobić kopi  użytkownika i oprogramowania z jakiego korzystasz  i przywrócić to po instalacji nowego WIN xxx.

Nie potrafisz  odinstalować  aktualizacji i nie wiesz gdzie je  szukać !? , a  mi wypominasz że się uczepiłem formatu  " jak pies kota ogona ".

Cztery godziny  pustej dyskusji  to już dwa razy bym to zrobił  i by działało jak trzeba.

Nr aktualizacji szukasz w ustawieniach > aktualizacje  i robisz to   w konsoli jako administrator:

np.

wusa /uninstall /kb:2976978

są i inne sposoby ,ale co ja tam wiem umiem tylko formatować.

Koniec kropka - powodzenia.

Sam zacząłeś dyskusje na tym poziomie a ja tylko się do niego zniżyłem, żeby się dostosować. Tym komentarzem tylko mnie utwierdziłeś w przekonaniu, że ta podstawówka była dobrym porównaniem. Jak ktoś przyjedzie na myjnie umyć auto to też mu powiesz, że lepiej kupić nowe bo nie wiadomo czym te wybrudził? Śmiać mi się chce jak ktoś myśli, że pozjadał wszystkie rozumy a daje rady, którymi można sobie tyłek podetrzeć. Albo mam odinstalować jakąś aktualizacje, nie wiadomo jaką, mimo że w logu nie jest napisane że, któraś z wcześniej instalowanych powoduje problem. Czy może mam odinstalować wszystkie? Po prostu <facepalm> Daj się wykazać rozsądniejszym użytkownikom i nie pogrążaj się już. 

 

Godzinę temu, marcelgg napisał:

Nie masz przypadkiem podpiętego jakiegoś modułu Broadcom Bluetooth and Wireless Network ? Jeśli masz drivery od takiego sprzętu w systemie to masz przyczynę takiego stanu rzeczy... [Zawartość widoczna tylko dla zalogowanych użytkowników] Ten błąd występował przy aktualizacji z Win7 lub Win8 na Win10 jak również po którejś aktualizacji Win10 gdy w systemie znajdowała się karta z chipsetem Broadcom.

Dziękuję za trop, coś kojarzę, że BT prawdopodobnie jest właśnie od Broadcomu, usunięcie ich z systemu może pomóc? Nie jestem pewien czy to były te akurat ale wydaje mi sie, że te kilka miesięcy temu próbowałem, upewnię się jutro w pracy 

Share this post


Link to post
Share on other sites
Godzinę temu, bladesss napisał:

Sam zacząłeś dyskusje na tym poziomie a ja tylko się do niego zniżyłem, żeby się dostosować. Tym komentarzem tylko mnie utwierdziłeś w przekonaniu, że ta podstawówka była dobrym porównaniem. Jak ktoś przyjedzie na myjnie umyć auto to też mu powiesz, że lepiej kupić nowe bo nie wiadomo czym te wybrudził? Śmiać mi się chce jak ktoś myśli, że pozjadał wszystkie rozumy a daje rady, którymi można sobie tyłek podetrzeć. Albo mam odinstalować jakąś aktualizacje, nie wiadomo jaką, mimo że w logu nie jest napisane że, któraś z wcześniej instalowanych powoduje problem. Czy może mam odinstalować wszystkie? Po prostu <facepalm> Daj się wykazać rozsądniejszym użytkownikom i nie pogrążaj się już. 

 

Dziękuję za trop, coś kojarzę, że BT prawdopodobnie jest właśnie od Broadcomu, usunięcie ich z systemu może pomóc? Nie jestem pewien czy to były te akurat ale wydaje mi sie, że te kilka miesięcy temu próbowałem, upewnię się jutro w pracy 

Ty naprawdę nie umiesz czytać ze zrozumieniem  co  ci napisałem parę postów  wyżej  o BT  ! ?  -  mniej dopalaczy a więcej rozumu !.

A jak już jesteś taki  zamulony  to radzę ci  jak  będziesz przechodził  koło warzywniaka  do podejdź  do wagi  połóż  swoja głowę na niej  i tam masz taki znaczek buraki  to naciśnij  go.

 

Share this post


Link to post
Share on other sites
4 godziny temu, woj_ani217 napisał:

Ty naprawdę nie umiesz czytać ze zrozumieniem  co  ci napisałem parę postów  wyżej  o BT  ! ?  -  mniej dopalaczy a więcej rozumu !.

A jak już jesteś taki  zamulony  to radzę ci  jak  będziesz przechodził  koło warzywniaka  do podejdź  do wagi  połóż  swoja głowę na niej  i tam masz taki znaczek buraki  to naciśnij  go.

 

Daruj sobie te denne teksty bo może jak przestaniesz pi****lić jak niedorozwinięta ameba to ludzie zaczyną Cię rozumieć.  Pisałeś, no i co? Na Twoje pytanie odpowiedziałem. Kolega wyżej napisał konkretnie dlaczego na to trzeba zwrócić uwagę, ucz się od niego zamiast rzucać jakimiś półsłówkami. W ogóle po co się udzielasz w tym wątku? Żeby się nieudolnie dowartościować? Jak masz kompleksy to lecz je gdzie indziej i skończ tu spamować.

Share this post


Link to post
Share on other sites

Temat został rozwiązany. Idąc tropem podanym w linku, który wrzucałem wyżej zrobiłem rekonstrukcję bootloadera za pomocą Hiren's Boot i wbudowanego tam EasyBCD (celowo robiłem to zewnętrznym oprogramowaniem, żeby spróbować uniknąć problemu z uprawnieniami, o którym wspomniałem w pierwszym poście). Po tej operacji system zaktualizował się przy pierwszym podejściu. Dziękuję kolegom @marcelgg i @renatan za chęć pomocy i mimo wszystko @woj_ani217 również bo mimo spier****ego podejścia chyba jakaś chęć pomocy również była. Temat do zamknięcia

image.png.96e882f475100dfa5374de4c4b97e187.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information