Jump to content

Windows zwalnia po kilku dniach pracy


Recommended Posts

Witam,

Od 3 miesięcy walczę ze stabilnością swojego komputera. Potrzebuję, aby działał 24/7, natomiast po 2-3 dniach system strasznie spowalnia.


Objawy: utrata wydajności / zwolnienie ekranu - kursor myszy reaguje na przesuwanie z opóźnieniem, tj. przesuwa się bardzo powoli, reakcja na kliknięcie jest także opóźniona, no po prostu komputer zwalnia tak bardzo, że nie da się go używać - np. otwarcie eksploratora windows trwa ok 8 sekund (i dodatkowe 10s zanim kursor sie przemiesci nad ikonke i kliknie) .

Konfiguracja: 
-MB: Fatal1ty AB350 Gaming K4
-CPU: Ryzen X1700
-RAM: 2x16gb + 2x8gb (48gb)
-GPU: Aktualnie Radeon RX580 8GB VRAM
-Wcześniej był wsadzony GeForce (dwa budżetowe jeden z 2gb ram, kolejny z 4gb + na test GTX 960) oraz Radeon R9 z 2gb ram
-Emulator monitora wsadzany do portu DVI (z komputerem łączę się tylko zdalnie przez Anydesk, bez tego nie widziałbym obrazu wiekszego niz 640x480)

Diagnoza:
Jako, że pierwsza karta z nvidii mi padła i powodowała bluescreeny / restarty postanowiłem wymienić na inną. Niestety, sterowniki OpenGL ciągle powodowały błędy. Wsadziłem GTX960 - również blędy związane z opengl / crash aplikacji podobnie jak na słabszej siostrze. Jako, że ciągle pokazywało błąd sterowników, postanowiłem sprawdzić coś ze stajni AMD, Zakupiłem Radeona. Wszystko wydawało się w porządku - aplikacja się odpalała, żadnych bluescreenów, crashy.
Szczęśliwy, że rozwiązałem problem byłem może około 20h. Po 20h użytkowania komputer zwalniał. Pomagało zamknięcie kilku z 20 odpalonych jednocześnie aplikacji korzystających z OpenGL do wyświetlania obrazu. Ostatecznie kupiłem RX580, problem jest nadal, ale komputer staje się nie nieużywalny dopiero po około 2-3 dniach. 
Dołączam screen z menadzera zadan w momencie, gdy komputer jest "zlagowany" - jak widać, użycie podzespołów jest na niskim poziomie + ustawień karty graficznej - nie wiedzieć dlaczego, Windows kradnie mi strasznie duzo ramu dla grafiki (o ile to ma jakies znaczenie)

 

Probowalem czyscic system CCleanerem oraz ADWCleanerem.

 

 

[Zawartość widoczna tylko dla zalogowanych użytkowników]

Link to post
Share on other sites
Godzinę temu, wiktorynek napisał:

Typowy wyciek pamięci. To właśnie to powoduje to spowolnienie. Jakaś aplikacja lub sterownik.

To teraz się pogubiłem... używam w sumie tylko virtualboxa (jako czesc Genymotion) - spróbuje wyjąć te 2x8gb.. ale oprócz tego jest jakiś pomysł co z tym zrobić ?

Jako user raczej mam małe możliwości naprawy tego?

Link to post
Share on other sites

Znajdź aplikację która to powoduje. Zacznij od kontrolowania menedżera zadań. Zaktualizuj wszystkie sterowniki i programy do najnowszych wersji. Odinstaluj te sterowniki grafiki i zobacz czy nadal występuje problem. Być może trzeba będzie stopniowo odinstalowywać aplikacje, a na końcu inne sterowniki i obserwować co to powoduje.

Link to post
Share on other sites
Cytat

Znajdź aplikację która to powoduje.

To akurat udało mi się ustalić już wcześniej. Genymotion który jest zależny od Virtualbox 5.1.26 (w innych nie działa dźwięk).
Kontaktowałem się z supportem, wysłałem im logi o które prosili, lecz szukam dalej na własną rękę.

Dziwnym jest dla mnie, że używany przeze mnie system nagle zaczął się psuć po 8 miesiącach, gdzie jeszcze 2 miesiące wcześniej cieszyłem się dwutygodniowym uptimem.

Za kilka godzin znowu utraci wydajność, to wtedy wyjmę jeszcze te pamięci 2x8GB jak proponował Fenir, zwłaszcza, że były dokupione mniej więcej wtedy, gdy zaczęły się dziać pierwsze problemy i stwierdziłem, że może komputerowi przyda się zastrzyk pamięci... aczkolwiek, sprawdzałem już całość memtestem i nie pokazały żadnego błędu. Kości to Corsair Vengeance DDR4.

Cytat

Zacznij od kontrolowania menedżera zadań.

Szczerze, to nie wiem, czego mam dokładnie tam szukać. Użycie procesora ciągle jest poniżej 20%, pamięci oscylują w 55-60%, aktualnie mam 26,2/47,9 (55%)

W zakładce wydajność -> pamięć wolnej pamięci pokazuje mi 6GB, około 16GB jest buforowane i 26GB w użyciu.

Cytat

Zaktualizuj wszystkie sterowniki i programy do najnowszych wersji. Odinstaluj te sterowniki grafiki i zobacz czy nadal występuje problem.

Sterowniki i bios mam aktualny, Genymotion aktualne, Virtualboxa nie mogę zaktualizować bo nowsza wersja jest niekompatybilna.
Sterowników od grafiki też raczej odinstalować nie mogę, bo Genymotion wymaga OpenGL, a oprócz tego Windows sam mi instaluje jakieś swoje starsze.

Link to post
Share on other sites
Godzinę temu, nexiu napisał:

wyjmę jeszcze te pamięci 2x8GB

Bardzo mało prawdopodobne, aby to miało wpływ - pamięć fizyczna raczej nie ucieka. ;) A wadę wykluczyłeś.

Godzinę temu, nexiu napisał:

nie wiem, czego mam dokładnie tam szukać.

programu lub procesu który zajmuje tyle ramu

Godzinę temu, nexiu napisał:

Sterowników od grafiki też raczej odinstalować nie mogę, bo Genymotion wymaga OpenGL, a oprócz tego Windows sam mi instaluje jakieś swoje starsze.

I tu może być sedno sprawy. Wcześniej nie miałeś problemów, bo były inne sterowniki. Win 10 przez WU zaktualizował je - wątpię, aby były najnowsze. Zaktualizuj sam ze strony AMD: [Zawartość widoczna tylko dla zalogowanych użytkowników]

Instaluj w trybie czystej instalacji.

Jak będziesz miał kiedyś czas, a problem nadal będzie występował i nie znajdziesz nic innego w menedżerze zadań, to niestety będziesz musiał dla testu odinstalować te sterowniki grafiki na jakiś czas(kilka dni), aby potwierdzić lub zaprzeczyć przypuszczeniom.

Link to post
Share on other sites

Właśnie mam najnowsze z czystej instalacji, pobrane z AMD, jak je próbuje odinstalować, żeby nie było sterowników od AMD w systemie, to właśnie wtedy WU instaluje swoje, starsze.

Żaden program ani proces nie zajmuje mi tak wiele ramu, mam odpalonych 19 maszyn wirtualnych które mają przydzielone 768mb ram.

Nie uruchomię ich bez sterowników graficznych, a komputer wykorzystuję tylko korzystania z tych wirtualek.

[Zawartość widoczna tylko dla zalogowanych użytkowników]

Link to post
Share on other sites
12 minut temu, nexiu napisał:

jak je próbuje odinstalować, żeby nie było sterowników od AMD w systemie, to właśnie wtedy WU instaluje swoje, starsze

Logiczne - musisz wyłączyć WU lub pozostawić kompa offline.

 

19 x 768 to prawie 15GB + dodaj te procesy VB + procesy tego playera + to co zwykle zajmuje windows ze sterownikami i programami

 

A jeszcze jedno pytanie - czy jak odpalisz np tylko 5 x VB i pozostawisz na kilka dni to też zwalnia? Tyle maszyn wirtualnych to spore obciążenie + każda powiększa stale swoje zasoby na dysku i w pamięci.

Link to post
Share on other sites
4 minuty temu, wiktorynek napisał:

Logiczne - musisz wyłączyć WU lub pozostawić kompa offline.

 

19 x 768 to prawie 15GB + dodaj te procesy VB + procesy tego playera + to co zwykle zajmuje windows ze sterownikami i programami

 

A jeszcze jedno pytanie - czy jak odpalisz np tylko 5 x VB i pozostawisz na kilka dni to też zwalnia? Tyle maszyn wirtualnych to spore obciążenie + każda powiększa stale swoje zasoby na dysku i w pamięci.

Raczej nie powinno zwalniac, ale niestety nie moge sobie pozwolic na tak dluga przerwe w dzialaniu tych VB. 
Natomiast, jak komputer zacznie lagowac, i zamkne 3-5 okienek playera (co jest rownoznaczne z zamknieciem danego procesu VB) to komputer odzyskuje stabilność.

Właśnie wyciągnąłem pamięci i uruchamiam na nowo wszystko, dam znać za 2-3 dni najpóźniej, jak z problemem (wątek obserwuję na bieżąco)

Link to post
Share on other sites
1 minutę temu, nexiu napisał:

niestety nie moge sobie pozwolic na tak dluga przerwe w dzialaniu tych VB

Rozumiem, ale inaczej nie znajdziesz przyczyny.

2 minuty temu, nexiu napisał:

jak komputer zacznie lagowac, i zamkne 3-5 okienek playera (co jest rownoznaczne z zamknieciem danego procesu VB) to komputer odzyskuje stabilność

I tu być może masz odpowiedź - za dużo maszyn wirtualnych. Jak ja odpalę na moim laptopowym i7 10 maszyn VB to też tak zwalnia mysz i wszystko.

Kup mocniejszy procesor(sprzęt). :D

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information