Skocz do zawartości
doop

[solved] windows 10, openSUSE, Grub2 - windows nie działa poprawnie

Rekomendowane odpowiedzi

Witam. Mam problem z Windowsem 10 Pro zainstalowanym na jednym dysku z OpenSUSE Leap 42.3.

 

Laptop HP ProBook 650 G1. Dysk HDD. 4 partycje MBR:

sda1 - Linux

sda2 - Linux Swap

sda3 - Linux /home

sda4 - Windows (ntfs)

 

Instaluję Windowsa. Wszystko działa poprawnie. Wszystkie aktualizacje się wgrywają.

Następnie instaluję Linuxa. Jako program rozruchowy jest Grub2. Wykrywa on windowsa normalnie i pozwala na jego uruchomienie. Niestety ale teraz w windowsie dzieją się "dziwne" rzeczy:

- sam system działa poprawnie, bez żadnych błędów itp.,

- instalacje niewymagające ponownego uruchomienia instalują się poprawnie,

- instalacje wymagające ponownego uruchomienia zaczynają się instalować, następnie komputer należy uruchomić ponownie i instalacja jest kontynuowana. Niestety, w końcu, wyskakuje komunikat, ze aktualizacja nie może być zainstalowana i następuje wycofywanie zmian. Po wszystkim komputer uruchamia się poprawnie, a windows znów twierdzi, że ma do zainstalowania aktualizacje.

- nie mogę uruchomić systemu w trybie bez sprawdzanie podpisów sterowników (to była przyczyna, że zacząłem wnikać głębiej w temat) bo po wybraniu opcji "uruchom ponownie" z wciśniętym przyciskiem "shift" mam do wyboru tylko opcję "Zamknij komputer". Nie ma np. opcji o ustawieniach zaawansowanych (a przed odbudową gruba są),

- problem z instalacją aktualizacji pojawił się przy aktualizacji z wersji 1709 do wersji 1803 (komputer mam od 2 miesięcy i była to pierwsza jego większa aktualizacja). Próbowałem wymusić aktualizację uruchamiając instalację z pendriva ale instalka w końcu stwierdziła, że "Instalator systemu Windows 10. Niestety, mamy problem z określeniem, czy na Twoim komputerze można uruchomić system Windows 10. Zamknij Instalatora i ponów próbę." A przecież uruchomiłem do spod windowsa 10 :)

- uruchamiając instalkę z bootlowanego pendriva nie mam opcji aktualizacji jest tylko możliwość zainstalowania "na czysto" z formatowaniem partycji lub bez, ale wtedy ostrzega, że jest tam stara instalacja i zostanie ona przeniesiona do katalogu Windows.old.

 

Co może być przyczyną tak działającego windowsa?

 

Krzysiek

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Mam podobny problem i myślę, że to dotyczy multi-boot'a. Na innym komputerze z identycznym pojedynczym systemem win 10 nie mam problemów.

Niezależnie od konfiguracji sprzętowej przy dual-boot'cie Win-Linux siadały mi aktualizacje zbiorcze w Win7 i w Win 10. Po naprawie BCD na Windowsowy mogłem normalnie aktualizować. Widocznie reboot przy aktualizacji nie może być zakłócony przez inny bootloader np. Grub.

Naprawa w stylu: https://www.laptopmag.com/articles/fix-0xc0000034-error-windows-10

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Problem rozwiązany. Za sugestią z innego forum zamieniłem miejscami windowsa z linuxem... i działa.

Czyli, najlepiej instalować windowsa na pierwszej partycji.

Problem uważam za rozwiązany.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×

Powiadomienie o plikach cookie