Skocz do zawartości
samson4x

Integracja post SP3

Rekomendowane odpowiedzi

Witam, robię moda Xp na własne potrzeby (normalny Xp - nie chcę PoSReady), bazuję na czystym SP3. Pobrałem poprawki [Zawartość widoczna tylko dla zalogowanych użytkowników] oraz [Zawartość widoczna tylko dla zalogowanych użytkowników]. Większość tych poprawek - w tym również IE8 i WMP11 (za pomocą WMP11 Slipstreamer) zainstalowało się poprzez NLite, ale pliki *.cab (np. wuweb.cab, muweb.cab, LegitCheckControl.cab itp pozostałe) za żadne skarby nie chcą się zintegrować, NLite wywala błąd przy próbie ich integracji, RVM Integrator również ich nie akceptuje. Teoretycznie udało się je zintegrować programem HFSLIP (umieszczając je w folderze HFCABS a obraz systemu w SOURCE), ale po utworzeniu potem iso i zainstalowaniu w ogóle nie ma w systemie tych poprawek z plików *.cab. Co mam z tym zrobić? Jak te pliki zintegrować do systemu? Nie chcę kompletu typu OnePiece bo chcę sam zdecydować o tym co ma być zintegrowane. Help please ☹️

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ja już nie mam materiałów do XP, ale jeśli dobrze pamiętam tak jak napisałeś w HFSLIP do HFCABS i powinno być OK. Taka ważna uwaga - integracja za pomocą HFSLIP powinna odbywać się w systemie XP niemodyfikowanym, bo wtedy wychodzą różne błędy.

2 godziny temu, samson4x napisał:

WMP11 (za pomocą WMP11 Slipstreamer)

Lepiej skorzystać z True Addona, analogicznie jak IE8, DX9.0c, NET 2.0, 3.5, 4.0

 

2 godziny temu, samson4x napisał:

Nie chcę kompletu typu OnePiece bo chcę sam zdecydować o tym co ma być zintegrowane.

Ale tam bez problemu odinstalujesz zbędne komponenty systemowo.

 

Tak na marginesie, nie wiem czy jest sens wyważać otwarte drzwi i w ogóle bawić się jeszcze w modowanie XP. Odchudzanie XP nic nie da. W dzisiejszych czasach 1GB ramu to mało nawet na XP. Winne są pamięciożerne programy.

Różnica między full POSReady, a kastratem wynosi jakieś 40MB ram, czyli nic. POSReady pozwala zachować jeszcze trochę bezpieczeństwa i ciut kompatybilności.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Integrowałem w HFSLIP właśnie na Xp SP3 czystym, nie wiem więc czemu nie zintegrowało ich poprawnie.

A jest MS Update jako Addon? Jeśli tak to skąd go pobrać?

 

Ps. HFSLIP zażądał obecności pliku wbemoc.cab w folderze HFCABS, bo bez tego ani rusz, udało mi się go ściągnąć gdzieś z neta o ile to poprawny plik.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
39 minut temu, samson4x napisał:

A jest MS Update jako Addon?

Tylko cab - w pakiecie OnePiece też są te pliki w formacie cab. Ogólnie były chyba exe, ale tego nie da się zintegrować do XP.

40 minut temu, samson4x napisał:

HFSLIP zażądał obecności pliku wbemoc.cab

Tak musi być, on eliminuje jakiś błąd SP3. Niestety baza HFSLIP już nie istnieje.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Rozumiem. Poszperałem troche i znalazłem program dxupac.exe (Nonno Fabio and OnePiece Update Pack/AddOn Creator INTL). Chyba tym ustrojstwem właśnie powstawały te wszystkie OnePiece. Zobaczę co się da zrobić tym programem.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
31 minut temu, samson4x napisał:

Poszperałem troche i znalazłem program dxupac.exe (Nonno Fabio and OnePiece Update Pack/AddOn Creator INTL). Chyba tym ustrojstwem właśnie powstawały te wszystkie OnePiece.

Tak i tym programem powstaje cały update pack, ale nie możesz dowolnie sobie integrować co chcesz. On powstał do obsługi określonej paczki. Tu masz całe repozytorium: mega:#F!ghEniZyD!Hin-l0Fy0BRlnG-wWcF0hw

A tu tematy: [Zawartość widoczna tylko dla zalogowanych użytkowników]

[Zawartość widoczna tylko dla zalogowanych użytkowników]

[Zawartość widoczna tylko dla zalogowanych użytkowników]

[Zawartość widoczna tylko dla zalogowanych użytkowników]

[Zawartość widoczna tylko dla zalogowanych użytkowników]

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
W dniu 1.05.2018 o 20:49, wiktorynek napisał:

Tak i tym programem powstaje cały update pack, ale nie możesz dowolnie sobie integrować co chcesz. On powstał do obsługi określonej paczki. Tu masz całe repozytorium: mega:#F!ghEniZyD!Hin-l0Fy0BRlnG-wWcF0hw

A tu tematy: [Zawartość widoczna tylko dla zalogowanych użytkowników]

[Zawartość widoczna tylko dla zalogowanych użytkowników]

[Zawartość widoczna tylko dla zalogowanych użytkowników]

[Zawartość widoczna tylko dla zalogowanych użytkowników]

[Zawartość widoczna tylko dla zalogowanych użytkowników]

Dzięki ☺️ A napisz mi jeszcze gdzie pobrać sterowniki SATA oraz SATA vII? Znalazłem sterowniki tutaj: [Zawartość widoczna tylko dla zalogowanych użytkowników] ale która to wersja? Bo na tym forum Mr.T zrobił 9w1 w którym do wyboru jest instalka z SATA oraz SATA vII. Potrzebuję obie wersje tych sterowników.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Tak, to są te sterowniki. A tu program do integracji: [Zawartość widoczna tylko dla zalogowanych użytkowników]

I uściślijmy - to nie są sterowniki SATA, SATA II czy SATA III, tylko sterowniki kontrolera AHCI/RAID zarządzającego dyskami. Jaki dysk SATA podłączysz do tego kontrolera przez jeden z portów SATA, to już nie ma znaczenia żadnego. W biosie musisz ustawić tryb AHCI bądź RAID i wtedy wraz ze sterownikami w takim trybie działa dysk z interfejsem SATA.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Ja rozumiem że te sterowniki są do obsługi AHCI/RAID, a nie SATA I, II czy III; tylko zastanawia mnie czym się różnią sterowniki SATA od SATA v2 ? Dla przykładu Win Xp prezesa z tutejszego forum: [Zawartość widoczna tylko dla zalogowanych użytkowników] jak widać - do wyboru (9 in 1) wersja z SATA bądź SATA v2. O to mi konkretnie chodzi czym się to właściwie różni? 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

A więc które z tych sterowników [Zawartość widoczna tylko dla zalogowanych użytkowników] to wersja v1 a która v2? Sorki że tak pytam i drążę temat ale chcę mieć pewność poprostu.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

NiKKA w tamtym obrazie zrobił to wg własnego uznania. "v2" to wymyślona przez niego nazwa własnego zestawu sterowników na zasadzie "jak nie ruszy to pierwsze, to wybierz drugie". Oficjalnie nie ma żadnego podziału v1/v2, więc nie ma co drążyć. Wybierz to, co podał Ci @wiktorynek

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×

Powiadomienie o plikach cookie