Jump to content
WinClub
razor1995

Aktualizacja pakietów w dystrybucjach bazujących na Debianie

Recommended Posts

sudo apt-get update - tym poleceniem aktualizujemy listę dostępnych pakietów, 

sudo apt-get upgrade - tym poleceniem aktualizujemy zainstalowane pakiety do najnowszej wersji,

sudo apt-get dist-upgrade - tym poleceniem aktualizujemy zainstalowane pakiety, ich zależności i usuwany niepotrzebne,  nieaktualne wersje, 

sudo apt-get -f install - aktualizacja zależności, 

 

 

sudo - dodajemy, jeśli nie pracujemy na koncie roota. Podnosi uprawnienia dla wykonywanego procesu.

Share this post


Link to post
Share on other sites

1 krok poszlo ok 

 

2 krok 

gxxx@Lenovo-xxxxx ~ $ sudo apt-get upgrade
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Należy uruchomić "apt-get -f install", aby je naprawić.
Następujące pakiety mają niespełnione zależności:
 brave : Wymaga: git
E: Niespełnione zależności. Proszę spróbować użyć -f.              
 
3krok
gxxx@Lenovo-xxxxx~ $ sudo apt-get dist-upgrade
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
Należy uruchomić "apt-get -f install", aby je naprawić.
Następujące pakiety mają niespełnione zależności:
 brave : Wymaga: git
E: Niespełnione zależności. Proszę spróbować użyć -f.
 

co nie tak robie ?

Share this post


Link to post
Share on other sites
co nie tak robie ?

 

 

 

Należy uruchomić "apt-get -f install", aby je naprawić.

Następujące pakiety mają niespełnione zależności:

 brave : Wymaga: git

E: Niespełnione zależności. Proszę spróbować użyć -f.          

 

Masz niespełnione zależności (brak klienta githuba). Skrypt przecież Ci napisał, co masz zrobić :P

Share this post


Link to post
Share on other sites

a mozesz jasniej napisac co mam zrobic,nie znam sie tak dobrze jak ty :-)

 

 

Należy uruchomić "apt-get -f install", aby je naprawić.

Następujące pakiety mają niespełnione zależności:

 brave : Wymaga: git

E: Niespełnione zależności. Proszę spróbować użyć -f.      

 

Jaśniej się nie da.

 

 

 

apt-get -f instal

install

 

Litera L jest podwójna. 

Share this post


Link to post
Share on other sites
guma@Lenovo-Y50-70 ~ $ apt-get -f install

E: Nie udało się otworzyć pliku blokady /var/lib/dpkg/lock - open (13: Brak dostępu)

E: Nie udało się zablokować katalogu administracyjnego (/var/lib/dpkg/), czy użyto uprawnień administratora?

 

co zas tm razem zle :)

Share this post


Link to post
Share on other sites

 kolega czasem nie ma full wypas mada fu*ka optymalizacji i var nie ma w ram dysku :)

Po restarcie pierwsze co robisz odpal terminal i wklep to co masz wklepać . Zapisz sobie na pulpicie plik tekstowy i w nim polecenie . Kopiuj wklej enter i czekamy co sie zrobi . 

Modyfikacja fstab cos ala taki wpis -

tmpfs /var/cache/apt/archives tmpfs defaults,noatime 0 0

Edited by FAFAŁ

Share this post


Link to post
Share on other sites

 

 


guma@Lenovo-Y50-70 ~ $ apt-get -f install
E: Nie udało się otworzyć pliku blokady /var/lib/dpkg/lock - open (13: Brak dostępu)
E: Nie udało się zablokować katalogu administracyjnego (/var/lib/dpkg/), czy użyto uprawnień administratora?

A sudo to gdzie? :E

 

sudo apt-get -f install

Share this post


Link to post
Share on other sites

A sudo to gdzie? :E

 

sudo apt-get -f install

no widzisz nie wiem ze ma byc a ty sam zapomniales dopisac ,popraw w 1 poscie i dodaj sudo , bo masz

 apt-get -f install    :)

 

wszystkie komendy juz ok ,ostatnia tez 

 

guma@Lenovo-Y50-70 ~ $ sudo apt-get -f install
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności       
Odczyt informacji o stanie... Gotowe
0 aktualizowanych, 0 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
guma@Lenovo-Y50-70 ~ $ 

Share this post


Link to post
Share on other sites

 

 


Jeśli nie to nieźli idioci z was, pogratulować braku inteligencji - sam chciałbym być czasem tak mało rozgarniętym/świadomym.

Ależ jesteś idiotą, nie musisz nas dodatkowo w tym przekonaniu utwierdzać. Udowodniłeś to powyższym postem. 

 

P.S. 99% superkomputerów nie pracuje ani pod Linux ani pod Windows. Mają własne, wbudowane systemy, Panie małorozgarnięty.

 

P.S.2. Proszę moderatora o wlepienie warna temu userowi, obraża innych użytkowników.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information